Probleem Mailserver
Incident Report for ITPcloud
Resolved
Mailserver functioneert weer volledig.
Posted Mar 09, 2022 - 16:52 CET
Update
We are continuing to investigate this issue.
Posted Mar 09, 2022 - 16:49 CET
Investigating
Probleem worden onderzocht.
Posted Mar 09, 2022 - 16:49 CET
This incident affected: E-Mail (Mailserver).